Hospedagem PHP mais rápida e segura

Postado em: 5 de novembro de 2014 - Por: Marcelo Ramos

 

Hospedagem PHP 5.5, 5.4 e 5.3

 

 

A InfoLink disponibiliza em seus servidores de hospedagem PHP versões 5.3, 5.4 e 5.5 – tanto na plataforma Linux, quanto na plataforma Windows. Em ambas as plataformas a versão 5.5 do PHP é instalada como padrão.

Por que migrar de versão?

Updates de versão do PHP além de trazerem novidades e melhorias para os desenvolvedores, corrigem bugs que tornam os sites mais seguros, reduzindo as possibilidades de invasões e falhas de segurança.

Alguns exemplos de bugs corrigidos nas versões instaladas na hospedagem InfoLink são CVE-2014-3538, CVE-2014-3587, CVE-2014-2497, CVE-2014-5120 e CVE-2014-3597.

Estudos indicam que códigos que utilizam a versão 5.4 do PHP chegam a ser até 40% mais rápidos que os que utilizam a versão 5.3.

O que muda nas novas versões?

Versão 5.4

  • Nova sintaxe na linguagem, incluindo Traits (mecanismos para ajudar a reutilização de código), sintaxe simplificada de arrays, entre outros;
  • Redução do consumo de memória e melhora na performance;
  • Limpeza na base de código com a remoção de funcionalidades descontinuadas.

Versão 5.5

  • Melhorias no controle de erros e exceções (exceptions);
  • Inclusão de uma API password hashing, que busca facilitar o desenvolvimento de rotinas de encriptação de senhas;
  • Arrays e strings podem agora ser desreferenciados (defeferencing) para serem acessados diretamente.

Para saber em detalhes o que muda, acesse o site do PHP:

Qual a versão do PHP estou utilizando?

A versão do PHP utilizada em seu site pode ser verificada acessando a opção Recursos no Painel de Controle de Hospedagem.

Você também pode criar um pequeno script com uma chamada a função phpinfo(). Um exemplo funcional deste script pode ser verificado em nossa WIKI.

Como ativar o PHP na plataforma Windows?

O PHP também roda na plataforma Windows 2012. Servidores de plataformas anteriores não permitem sua utilização.
Caso deseje ativar o PHP em seu site hospedado na plataforma Windows, você deve abrir um chamado em nosso Helpdesk solicitando a ativação e informando qual versão deseja ativar: 5.4 ou 5.5.

Como altero a versão do PHP de meu site?

Caso deseje alterar a versão do PHP que seu site está utilizando, você deve abrir um chamado em nosso Helpdesk solicitando a ativação e informando qual versão deseja ativar: 5.3, 5.4 ou 5.5.

Após migrar de versão eu posso continuar utilizando a opção de configuração do PHP.INI no Painel de Controle?

Sim. Todas as funções de administração e configuração do PHP estão disponíveis no Painel de Controle para todas as versões do PHP, tanto na plataforma Linux, quanto na plataforma Windows. Acesse nossa WIKI e verifique as configurações que podem ser realizadas a qualquer momento.

 

Leia também